Android Studio 3,舊專案的gradle問題怎麼解決,為什麼?

作者 | 2017-10-29

找不到gradle版本

當使用Android Studio 3.0打開舊專案時,會自動檢查該專案中使用的gradle版本與目前Android Studio中的Gradle Plugin工具,舊專案可能會找不到使用的gradle版本而出現如下的問題:

上圖是經過搜尋本機與網路上的jcenter檔案庫後,仍然找不到舊專案的gradle問題提示。

Google的Maven檔案庫

因為Google在日益眾多的Android開發需求下,自行建立了專用的Maven檔案庫,只是目前專案中的build.gradle設定檔並未指定Google的檔案庫。可以手動打開專案(Project)的build.gradle檔自行新增一行,或按下上圖提示的「Add Google Maven repository and sync project」,在repositories區塊中加上「google()」即可,如下圖:

昇級Gradle Plugin

Android Studio 3.0使用gradle 4.1版,在4.1版支援了google檔案庫,而Gradle Plugin工具也應該昇級到3.0.0以上,因此,自動檢查後會出現提示對話框,要求將目前的Gradle Plugin工具昇級至3.0.0,請按下「Update」昇級即可,如下圖:

若是直接使用Android Studio 3.0建立的新專案就簡單了,新建立專案中的build.gradle設定就已經是最新版本,並使用Google的Maven檔案庫,如下圖:

有關Gradle Plugin的版本釋出文件:

https://developer.android.com/studio/releases/gradle-plugin.html

 

相關文章:

Category: Android Android Studio 3 標籤:, ,

關於 Hank Tom

專長為程式語言、雲端服務開發,Linux系統管理, 任職:利拓科技 技術長,海林行動科技 技術總監 輔仁大學 兼任助理教授 ,為 Android高效入門>深度學習、CentOS 7建置、管理與伺服器架設實戰、Java網路程式設計、雲端網頁程式設計-Google App Engine應用實作 等書作者

發表迴響

你的電子郵件位址並不會被公開。 必要欄位標記為 *