Android高效入門-範例出現 Packages Unavaliable 對話框的解法 (已修正)

By | 2016-06-30

[已修正] 全書範例已重新上傳,不會再出現此問題囉~

錯誤畫面

mag_p_u_01

解決方式

請開啟Gradle Scripts 下的 build.gradle(Module: app)

更改buildToolsVersion如下

再同步專案,請點選右上角[Try Again]mag_p_u_02

或選取Tool Bar 同步專案圖示

mag_p_u_04

待專案同步完成後即可正常作業。

原因

本書範例為確保開發工具為最新版本,故撰寫範例時 Build-tools 採用 preview 版 (非正式版本),而當時24.0.0-rc2、24.0.0-rc3 皆會自動到Google Repository下載24.0.0-preview這個名稱的檔案庫,約一個月前24.0.0正式發佈後的某天,Google將因應rc2與rc3的檔案庫24.0.0-preview 刪除了,所以build專案時會出現Packages Unavaliable。

相關文章:

發表迴響

你的電子郵件位址並不會被公開。 必要欄位標記為 *